Revision [2120]

This is an old revision of HowToSetUpScim made by Puppyite on 2009-10-12 19:50:22.

 

Installing Scim and Related Packages


This article discusses installing Scim and related packages by using precompiled packages.

Whichever method you use for installing scim, you will need suitable Unicode-capable fonts. See this section for further details.

Depending on your language choice, you may also need to set up an alternative keyboard layout.



Some scim and scim-bridge files are available here:

http://www.puppylinux.ca/members/Irihapeti

If the above link isn't working, they are also available from http://www.puppylinux.asia/members/Irihapeti
The username is "puppy" and the password is "linux" (without the quotes).

These were mostly compiled on Puppy 2.17 and have been tested in Puppy 3.01 and 4.00. The scim-bridge package contains the scripts needed to set up the configuration files so that the software will work automatically. Usually, it is sufficient to restart the X server; rebooting isn't needed.

Important:
Please download all your packages from the above link. Versions from other websites may have been compiled differently, and this is likely to mean that they won't work unless you edit some configuration files by hand.

You will need:

– Where an option has more than one file, e.g. m17n, you need all of them.

Install the packages in the order given and restart the X server. Scim should be ready to use.

If you are using Puppy 4.2, you need to install gtk+-2.12.1-xinput.pet. If you are going to be compiling programs (i.e. you have devx_420.sfs installed), you will also need the _DEV, _DOC and _NLS versions of this package. All these packages are available from the above two links.



Notes about individual modules

All these options can be installed at the same time if you wish.




Please Note:

At the moment, GTK only can be counted on to work. Work on QT3 and QT4 support is in progress.

Fortunately, most of the pre-installed Puppy applications will work with Scim-GTK.


If you need further help post a message here.



MultiLingualPuppy



Categories
CategoryAdditionalSoftware
Valid XHTML :: Valid CSS: :: Powered by WikkaWiki