HomePage > Software Index > Internet

libflashplayer for Adobe Flash

Allow Flash applications to be run usually for a web browser. A typical examples include video streaming and games.

Installation
Install using either package, or GetFlash tool:

Package option
Via software package:
download the .tar.gz file
decompress it to extract its content:
tar xfv install_flash_player*.tar.gz

replace any existing file at /usr/lib/mozilla/plugins/libflashplayer.so
re-start the Web browser


GetFlash tool option
See GetFlash page. This tool downloads and install Flash.

dependencies
+bzip2,+cairo,+fontconfig,+freetype,+glib,+libnspr4,+libnss3,+libnssutil3,+pango,+pcre,+pixman,+libplc4,+libplds4,+libsmime3,+libssl3

Linux support

Flash version

Configuration
for full functionality ensure that the Web browser's JavaScript setting is enabled:
SeaMonkey: Edit > Preferences > Advanced > Scripts & Plug-ins > Enable JavaScript for Browser
Opera: Tools > Preferences > Advanced > Content > Enable JavaScript
Firefox: Edit > Preferences > Content > Enable JavaScript

ldd /usr/lib/mozilla/plugins/libflashplayer.so



Also on the Wiki
Chromium - allows later version of Flash than 11.2 on Puppy Linux
FlashExtractor - view and manipulate Flash files
GetFlash
Gnash - Alternative Flash Player



Categories
CategoryMultimedia
CategorySoftwareLibraries
CategorySoftware
Comments [Hide comments]
[Comment deleted]
[Comment deleted]
[Comment deleted]
[Comment deleted]
Comment by darkcity
2012-08-26 10:39:28
Thanks for the reply and all the work you put into the wiki.

FlashPlayer supports ActionScript which is used to create web apps
from Wikipedia - "Later versions added functionality allowing for the creation of Web-based games and rich Internet applications with streaming media (such as video and audio). Today, ActionScript is suitable for use in some database applications, and in basic robotics, as with the Make Controller Kit."

I've removed the link to version 11.2r202, I thought that was the latest version. I see 11.2.202.238 is the current version. I'm thought the PPM would have the latest version too, but that is even more out of date.

I've shrunk the icon down using height="48"
Comment by node-6cb.pool-1-2.dynamic.totbb.net
2016-09-15 06:41:08
slacko64_21549
Ha! for 64 bit puppy, put flash plugin from adobe here: /usr/lib64/mozilla/plugins/libflashplayer.so
lib64 instead of lib. duh
Comment by mx-ll-183.89.200-66.dynamic.3bb.co.th
2017-04-04 21:22:49
now called libpepflashplayer.so
not called libflashplayer.so any more
Valid XHTML :: Valid CSS: :: Powered by WikkaWiki